Welcome to the Jeep Forum.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

<<<<<< Register to remove these ads >>>>>>


Go Back   Jeep Forum > Jeep Forum - Jeep Models > Liberty Forum
Become a Supporting Member         Become a Preferred Vendor

Liberty Forum

02 Liberty Engine probs


This is a discussion on 02 Liberty Engine probs within the Liberty Forum forums, part of the Jeep Forum - Jeep Models category!
My 02 Liberty (197,000 mi) started missing real bad. engine codes were P0141, P0161, P0202, P0302. I replaced the #2 ...


Reply
 
LinkBack Thread Tools Display Modes
Old 04-26-2012, 08:24 AM   #1 (permalink)
Junior Member
 
Join Date: Apr 2012
Name: dave
Posts: 2
Default 02 Liberty Engine probs
My 02 Liberty (197,000 mi) started missing real bad. engine codes were P0141, P0161, P0202, P0302.
I replaced the #2 injector, plug & coil but it hasn't helped. How can I test the injection wiring & where else could the problem be?
davetheelectrician is offline   Reply With Quote
Old 04-26-2012, 09:18 PM   #2 (permalink)
 
Dave's Avatar
Super Moderator
 
Join Date: Jun 2010
Location: Upstate NY
Name: Dave
Posts: 639
Default
Originally Posted by davetheelectrician View Post
My 02 Liberty (197,000 mi) started missing real bad. engine codes were P0141, P0161, P0202, P0302.
I replaced the #2 injector, plug & coil but it hasn't helped. How can I test the injection wiring & where else could the problem be?
Hi Dave. Welcome to the forum.

P0141=HO2S heater performance-bank 1 sensor 2 (drivers side after tha cat sensor)

P0161=HO2S heater performance-bank 2 sensor 2 (pass side after the cat sensor)

P0202= Injector 2 control circut

P0302 Cyl 2 misfire

Seems like you should have corrected the misfire with the replacement of the plug and coil pak.

The first 2 codes might be related to the misfire as the sensors after the cat measure the heat of the exhaust leaving the cat.

You could try double checking the connector to the #2 coil-pak and then reset the codes and see if they come back. I don't know what else to suggest.

Dave


__________________
05 Black KJ ....
Skids, Hooks, Lifted, A/T's, Bent Rock Rail, etc.....
Trail Rash from NY, Pa, and ONF Florida.....

Need More Stuff.......
Dave is offline   Reply With Quote
Old 04-27-2012, 09:47 AM   #3 (permalink)
Junior Member
 
Join Date: Apr 2012
Name: dave
Posts: 2
Default
Thanks for the quick reply. I have done some further diagnostics. A compression check shows 180 on all cylinders EXCEPT #2 which shows 0. The zero on 2 was a shock as I was expecting a possible LOW reading...but not THAT low! Could I be dealing with a thrown rocker arm?? I have heard this is a known bug in the 3.7 & 4.7 engines. Is there any other testing I can do before pulling the valve cover?
davetheelectrician is offline   Reply With Quote
Old 04-27-2012, 11:33 AM   #4 (permalink)
 
Dave's Avatar
Super Moderator
 
Join Date: Jun 2010
Location: Upstate NY
Name: Dave
Posts: 639
Default
As far as I know you would need to pull the valve cover to check. (but I am not a professional mechanic)

Dave


__________________
05 Black KJ ....
Skids, Hooks, Lifted, A/T's, Bent Rock Rail, etc.....
Trail Rash from NY, Pa, and ONF Florida.....

Need More Stuff.......
Dave is offline   Reply With Quote
Old 06-25-2013, 01:35 PM   #5 (permalink)
Junior Member
 
Join Date: Jun 2013
Name: Pedro
Age: 68
Posts: 1
Default
Hello, I just want to know how to reléase the oil pan after loose all bolts
pejofag is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 liberty ap8108 Liberty Forum 4 01-12-2014 03:34 PM
Engine Stopping While Driving (98 Grand Cherokee) rubberman15 Grand Cherokee Forum 1 01-30-2011 03:47 PM
Is there any Small Engine Mechanics here? davbell22602 The Lounge 1 08-04-2010 12:06 PM
Jeep grand cherokee. ABS light and Oil leaking from engine Candymancan Grand Cherokee Forum 6 07-01-2010 02:29 AM
Towing in your liberty.. Shaggy Liberty Forum 12 06-17-2010 06:51 PM